mirror of
https://github.com/NixOS/nix.git
synced 2024-11-21 22:32:26 +00:00
7 lines
262 B
Nix
7 lines
262 B
Nix
# Note: functions in nested structures, e.g. attributes, may be optimized away by pointer identity optimization.
|
|
# This only compares a direct comparison and makes no claims about functions in nested structures.
|
|
assert
|
|
(x: x)
|
|
==
|
|
(x: x);
|
|
abort "unreachable" |