mirror of
https://github.com/NixOS/nix.git
synced 2024-11-21 22:32:26 +00:00
10 lines
199 B
Nix
10 lines
199 B
Nix
let
|
|
countDown = n:
|
|
if n == 0
|
|
then throw "kaboom"
|
|
else
|
|
builtins.addErrorContext
|
|
"while counting down; n = ${toString n}"
|
|
("x" + countDown (n - 1));
|
|
in countDown 10
|