mirror of
https://github.com/NixOS/nix.git
synced 2024-11-25 00:02:25 +00:00
f29e7867a9
This reverts commitaeffdeffc8
, reversing changes made to723fdeb4f1
.
21 lines
486 B
Nix
21 lines
486 B
Nix
with import ./config.nix;
|
|
|
|
# A simple content-addressed derivation.
|
|
# The derivation can be arbitrarily modified by passing a different `seed`,
|
|
# but the output will always be the same
|
|
rec {
|
|
stub = mkDerivation {
|
|
name = "stub";
|
|
buildCommand = ''
|
|
echo stub > $out
|
|
'';
|
|
};
|
|
wrapper = mkDerivation {
|
|
name = "has-dynamic-drv-dep";
|
|
buildCommand = ''
|
|
exit 1 # we're not building this derivation
|
|
${builtins.outputOf stub.outPath "out"}
|
|
'';
|
|
};
|
|
}
|