mirror of
https://github.com/NixOS/nix.git
synced 2025-02-16 17:02:28 +00:00
![Robert Hensing](/assets/img/avatar_default.png)
This does not include any automation for the release branch, but is based on the configuration of https://github.com/NixOS/nix/pull/12349 pre-commit run -a nixfmt-rfc-style
50 lines
804 B
Nix
50 lines
804 B
Nix
# Some dummy arguments...
|
|
{
|
|
foo ? "foo",
|
|
}:
|
|
|
|
with import ./config.nix;
|
|
|
|
assert foo == "foo";
|
|
|
|
let
|
|
|
|
platforms =
|
|
let
|
|
x = "foobar";
|
|
in
|
|
[
|
|
x
|
|
x
|
|
];
|
|
|
|
makeDrv =
|
|
name: progName:
|
|
(
|
|
mkDerivation {
|
|
name =
|
|
assert progName != "fail";
|
|
name;
|
|
inherit progName system;
|
|
builder = ./user-envs.builder.sh;
|
|
}
|
|
// {
|
|
meta = {
|
|
description = "A silly test package with some \${escaped anti-quotation} in it";
|
|
inherit platforms;
|
|
};
|
|
}
|
|
);
|
|
|
|
in
|
|
|
|
[
|
|
(makeDrv "foo-1.0" "foo")
|
|
(makeDrv "foo-2.0pre1" "foo")
|
|
(makeDrv "bar-0.1" "bar")
|
|
(makeDrv "foo-2.0" "foo")
|
|
(makeDrv "bar-0.1.1" "bar")
|
|
(makeDrv "foo-0.1" "foo" // { meta.priority = 10; })
|
|
(makeDrv "fail-0.1" "fail")
|
|
]
|